CASUALE TRA


La funzione CASUALE TRA in Excel

La funzione CASUALE TRA è utilizzata per restituire un numero casuale che fa parte di un intervallo definito.


La funzione viene utilizzata per creare modelli di simulazione e per riempire i database di dati fittizi utili per la creazione di esempi, ad esempio.

La notazione su Excel della funzione è:

=CASUALE.TRA(minore;maggiore)

Quindi per procedere ci serviranno:
– un numero che sarà l’elemento più piccolo dell’intervallo
– un secondo numero che sarà l’elemento più grande dell’intervallo

Caso 1: vogliamo trovare un elemento casuale inserito in un intervallo.
In questo caso assumiamo che il numero più piccolo sia B2 e quello più grande sia B3.

La funzione sarà:

=CASUALE.TRA(B2;B3)

Caso 2: vogliamo sempre trovare un elemento casuale inserito in un intervallo, ma in questo caso definiamo che il valore dovrà essere fra 5 e 18.

La funzione sarà:

=CASUALE.TRA(5;18)

Caso 3: la funzione permette anche un’interessante evoluzione nel caso avessimo una lista con dei nomi.

Assumiamo di avere alcuni nomi nelle celle da B3 a B14. Nella nostra simulazione in questo caso vogliamo avere un nome casuale e non un numero.

Un escamotage è utilizzare le funzioni INDICE e CONTA.VALORI per aiutarci. Quindi in questo caso, se vogliamo avere un nome casuale, possiamo inserire la seguente formula:

=INDICE(B3:B14;CASUALE.TRA(1;CONTA.VALORI(B3:B14)))

Come funziona? In questo caso INDICE ci permette di orientarci nell’intervallo da B3 a B14.

La funzione ci serve invece per navigare fra il numero 1 e il numero maggiore dell’intervallo, ovvero il numero di valori totali che viene calcolato con CONTA.VALORI. Questo assumendo che non ci siano dei vuoti, altrimenti dovremo contare il numero di valori nell’intervallo.

Questa funzione è un’evoluzione della funzione CASUALE() che non permette di delimitare l’intervallo poichè restituirà sempre un valore compreso fra 0 e 1 includendo i decimali.

Esiste anche un’altra funzione piuttosto recente chiamata MATR.CASUALE che ci permette di creare in tempo reale un’intera matrice con numeri casuali, ma pure in questo caso la funzione considera unicamente valori compresi fra 0 e 1.

In linea di massima, la funzione che troveremo più di frequente è quella descritta in questo articolo mentre le altre sono utilizzate per motivi specifici, ad esempio matrici oppure simulazioni rapide.


Scopri altri casi pratici per la funzione CASUALE.TRA: