Generatore numeri casuali Excel

    Microsoft_Excel_Numeri_Casuali_Maggiore_Minore_Finale

    Generare numeri casuali può risultare un po' faticoso se non abbiamo uno strumento adatto. In questo articolo vediamo come generare numeri casuali utilizzando alcuni funzioni di Excel utili come CASUALE.TRA e MATR.CASUALE, puoi scaricare il file collegato all'articolo dal pulsante successivo.

    Vediamo tre casi separati:

    Numeri casuali

    Una funzione della quale non parleremo in questo articolo è la funzione CASUALE. Questa funzione permette di ottenere un numero casuale fra 0 e 1, un caso specifico che probabilmente non ci capiterà di utilizzare spesso sui nostri file.

    Assumiamo invece di voler ottenere un numero casuale inserito in un intervallo con un massimo e un minimo.

    Microsoft_Excel_Numeri_Casuali_Maggiore_Minore_Finale

    In questo caso dobbiamo utilizzare la funzione CASUALE.TRA, che è così composta:

    =CASUALE.TRA(minore;maggiore)

    Vediamo che è piuttosto intuitiva anche come utilizzo, in questo caso consideriamo le celle C4 (minore) e C5 (maggiore) con i valori 10 e 500. Quindi il valore della cella D10 sarà incluso fra i due numeri, in questo caso 374:

    =CASUALE.TRA(C4;C5)

    Dobbiamo avere un'attenzione particolare perchè ogni volta che ricalcoliamo il file o salviamo, il numero trovato sarà diverso. Spesso infatti vengono generati numeri random e poi sono copiati e incollati come valori per cancellare le formule.

    Generatore numeri casuali

    Vediamo invece come generare vari numeri casuali con una singola funzione, introdotta con Excel 365. Questa funzione si chiama MATR.CASUALE e risulta incredibilmente efficiente per creare un lungo elenco di numeri inseriti su un singolo foglio.

    Microsoft_Excel_Numeri_Casuali

    La notazione della funzione MATR.CASUALE è la seguente:

    =MATR.CASUALE([righe];[colonne];[min];[max];[intero])

    Vediamo come la funzione sia decisamente più completa rispetto a CASUALE.TRA, dato che possiamo anche definire il numero di righe, il numero di colonne e se i numeri debbano essere per forza interi o anche decimali.

    Essendo una matrice, righe e colonne delimitano quante celle debbano essere popolate dalla funzione. Se inseriamo 4 righe e 5 colonne, vuol dire che saranno riempite 20 celle (4x5). Se inseriamo 100 e 6, saranno riempite 600 celle (100x6) e così via. Questo ci evita di dover copiare la stessa formula numerose volte per avere un elenco definito e, inserendola una sola volta, riempiremo direttamente tutta l'area che ci interessa.

    Microsoft_Excel_Generatore_Numeri_Casuali

    In particolare, la formula inserita richiede 3 righe (cella C4), 3 colonne (C5), minimo valore 3 (C6), massimo valore 62 (C7) e numeri interi.

    Abbiamo quindi la formula che sarà semplicemente:

    =MATR.CASUALE(C4;C5;C6;C7;VERO)

    Come dicevamo, la particolarità è che questa funzione viene inserita una volta sola e copre tutte le celle dell'intervallo, come notiamo. In questo caso la funzione apparirà in un grigio chiaro, che indica come sia parte di una matrice e non possa essere modificata.

    Microsoft_Excel_Generatore_Numeri_Casuali_Dettaglio

    Generare numeri casuali per ottenere testi casuali

    Un caso particolare potrebbe essere ottenere un valore casuale da una lista di nomi predefinita. Se volessimo creare dei codici casuali, c'è un articolo dedicato.

    Anche in questo caso utilizzeremo due funzioni di Excel, ovvero INDICE e CASUALE.TRA. INDICE considera un intervallo e CASUALE.TRA selezionerà un numero casuale dall'intervallo di INDICE in maniera dinamica. Attenzione a eliminare prima tutti gli spazi per evitare errori, sia per questo caso sia il successivo.

    Microsoft_Excel_Valori_Casuali_CASUALE.TRA

    Vediamo come abbiamo l'intervallo da B4 a B8, che sono 5 giocatori diversi. La formula sarà quindi:

    =INDICE($B$4:$B$8;CASUALE.TRA(1;5))

    C'è ancora un altro caso che potremmo voler considerare, sempre parlando di valori testuali. Se non siamo certi di quanti siano i valori contenuti nell'intervallo possiamo utilizzare la funzione CONTA.VALORI che ci restituisce il numero di riferimenti dell'intervallo.

    Microsoft_Excel_Valori_Casuali_CONTA.VALORI

    La formula in questo caso sarà quindi:

    =INDICE($B$4:$B$8;CASUALE.TRA(1;CONTA.VALORI($B$4:$B$8)))

    In questo caso CONTA.VALORI delimita il valore massimo possibile dell'intervallo, ovvero il conteggio di tutti i valori dello stesso intervallo. Come dicevamo, bisogna fare attenzione e utilizzare una lista senza spazi per evitare errori. Questo secondo caso può essere indicato per intervalli molto lunghi, mentre il primo per intervalli di facile comprensione.

    Lascia un commento

    Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *