Contare celle errori Excel

In questo articolo scopriamo come contare celle che presentano errori su Excel. In particolare, questo procedimento può essere utile quando vi sono molti calcoli su un solo foglio e cerchiamo di individuare quali siano le celle con degli errori all’interno.

Generalmente, questi errori sono poi rivisti e magari nascosti utilizzando SE.ERRORE.

Microsoft_Excel_Contare_Celle_Errori_Excel_MATR.SOMMA.PRODOTTO

Contare errori Excel

Ecco come fare, utilizzando le formule MATR.SOMMA.PRODOTTO e VAL.ERR.

Formula generale:

MATR.SOMMA.PRODOTTO(- –VAL.ERR([intervallo_valori]))

Primo esempio: abbiamo una serie di valori nell’intervallo B4:B12 e vogliamo sapere quante contengano errori, di qualsiasi tipo siano. Consideriamo quindi:

– [intervallo_valori] = B4:B12

Formula pratica:

MATR.SOMMA.PRODOTTO(- -VAL.ERR(B4:B12))

Microsoft_Excel_Contare_Celle_Errori_Excel_SOMMA

Secondo esempio: nel caso abbiamo una versione più vecchia di Excel (da Excel 2016 in giù) possiamo risolvere con una seconda combinazione di formule. Il risultato sarà lo stesso, ma dovremo ricordarci di inserire la combinazione di formule con CTRL + SHIFT + ENTER. Questa è infatti una formula con array, che farà apparire delle parentesi graffe attorno alla nostra formula.

Questo è un aspetto molto importante da tenere in considerazione per la manutenzione del file, poichè se la formula fosse inserita unicamente con ENTER non funzionerebbe.

Formula generale:

=SOMMA(- –VAL.ERRORE(intervallo_dati))

In questo caso abbiamo quindi una somma dei valori di errore in un certo riferimento. Dobbiamo anche ricordarci del doppio trattino (- -) che viene utilizzato per trasformare valori VERO e FALSO in 1 e 0 (in inglese double unary).

Vediamo quindi la formula pratica dove troviamo le parentesi graffe { }:

{ =SOMMA(- –VAL.ERRORE($B$4:$B$12)) }

2 commenti su “Contare celle errori Excel”

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *