MATR SOMMA PRODOTTO

La funzione MATR SOMMA PRODOTTO in Excel

La funzione MATR SOMMA PRODOTTO è utilizzata per diversi motivi, principalmente per ottenere velocemente il totale della moltiplicazione fra due colonne. La funzione può anche essere impiegata per contare i valori in un intervallo o per effettuare una somma su una singola colonna.

La notazione su Excel della funzione è:

=MATR.SOMMA.PRODOTTO(matrice1;[matrice2];[matrice3]…)

Vediamo alcuni casi per semplificare la comprensione, essendo una funzione piuttosto sfaccettata nel suo utilizzo su Excel.

Caso 1: vogliamo moltiplicare due intervalli.

In questo caso, prendiamo l’intervallo da B1 a B16 e il secondo intervallo da C1 a C16.

Potremmo creare una colonna di supporto dove inserire la moltiplicazione fra i singoli valori, ad esempio:

– D1 = B1*C1

che sarà poi trascinata sulle altre celle. Alla fine inseriremo una somma e troveremo il valore complessivo.

La funzione semplifica questo processo dato che il totale può essere trovato facendo la seguente operazione:

=MATR.SOMMA.PRODOTTO(B1:B16;C1:C16)

Caso 2: contare valori.

La funzione può anche replicare le funzionalità di CONTA.SE. In questo caso definiamo di voler contare i valori nell’intervallo da B16 a B30 che presentino un certo carattere pari a “Aprile”.

In questo caso, la formula richiede una forma diversa:

=MATR.SOMMA.PRODOTTO(- -(B16:B30=”Aprile”))

Dobbiamo ricordarci di inserire – -( per far sì che la funzione restituisca il valore corretto. Se copiate la formula, rimuovete lo spazio fra i due trattini poichè è solo per aumentare la leggibilità.

Caso 3: replicare la funzione SOMMA.

Vogliamo sommare i valori di un certo intervallo, ad esempio da E4 a E25.

Possiamo utilizzare la funzione anche se generalmente si preferirà la funzione SOMMA. In particolare, la formula sarebbe la seguente:

=MATR.SOMMA.PRODOTTO(E4:E25)


Scopri altri casi pratici per la funzione MATR SOMMA PRODOTTO:

Microsoft_Excel_Media_Ponderata_Matr_Somma_Prodotto

Calcolo media ponderata

    In questo articolo, scopriamo come calcolare la media ponderata su Microsoft Excel con un file pratico e alcune funzioni di appoggio.