CERCA VERT

La funzione CERCA VERT in Excel

La funzione CERCA VERT è utilizzata per restituire, sulla stessa riga del foglio, un valore finale presente in una colonna a destra rispetto al valore di ricerca iniziale.



La funzione ha il suo corrispettivo per la ricerca su una singola colonna con la funzione CERCA.ORIZZ.

La notazione su Excel della funzione è:

=CERCA.VERT(valore; matrice_tabella; indice; [intervallo])

Quindi per procedere ci serviranno:
– un valore di partenza, che è il valore iniziale da cercare all’interno della matrice_tabella
– la matrice_tabella, che equivale all’intervallo nel quale effettuare la ricerca e che deve iniziare tassativamente dalla colonna nella quale si trovi il nostro valore iniziale
– l’indice, che è un numero pari al numero di colonne contando dalla colonna iniziale fino a quella dove si trova il valore che stiamo cercando
– l’intervallo determina invece se la corrispondenza deve essere approssimativa (VERO) o esatta (FALSO)

Esempio funzione Cerca Verticale Excel

CERCA.VERT -> Caso Tipico con corrispondenza esatta

In questo caso vediamo il caso standard della funzione CERCA.VERT. Cercheremo quindi un valore a destra sulla stessa riga.

Microsoft_Excel_Funzione_Cerca.vert_Falso

Nell’intervallo da B4 a B11 abbiamo una serie di nomi di giocatori NBA. Nell’intervallo da C4 a C11 vediamo i loro punteggi.

Vogliamo rendere la ricerca dinamica, quindi inseriamo 3 nomi di giocatori nell’intervallo E4:E6. Nell’intervallo da F4 a F6 vogliamo ottenere i loro relativi punteggi.

Vediamo quindi la formula da inserire in F4 per restituire il valore corretto e corrispondente a Luka Doncic.

=CERCA.VERT(E4;$B$4:$C$11;2;FALSO)

In particolare:

– E4 è il valore di partenza, ovvero il nome del giocatore. Questo valore si trova nella colonna B all’interno del primo intervallo

– $B$4:$C$11 è la matrice_tabella o intervallo di ricerca, dove sono contenuti sia i nomi dei giocatori sia i loro punteggi

– 2 è l’indice poichè stiamo cercando i punteggi che si trovano sulla seconda colonna (colonna 1 presenta i nomi dei giocatori, colonna 2 racchiude i punteggi)

– FALSO è l’intervallo perchè desideriamo la corrispondenza esatta e non approssimativa, in questo caso. Vogliamo sapere esattamente i punti del singolo giocatore


CERCA.VERT -> Caso Tipico con corrispondenza approssimativa

In questo secondo caso cercheremo sempre un valore a destra sulla stessa riga, ma non ci sarà necessità di una corrispondenza univoca.

Microsoft_Excel_Funzione_Cerca.vert_Vero

Nell’intervallo da B4 a B11 abbiamo un riferimento di punteggi. Ad esempio, per 0 punti non c’è valutazione, da 0 a 10 c’è F, da 10 a 20 c’è E e così via.

Vogliamo restituire una valutazione a seconda di alcuni punteggi di partenza in modo dinamico, quindi inseriamo 3 punteggi nell’intervallo E4:E6. Come nell’esempio precedente, nell’intervallo da F4 a F6 vogliamo ottenere un valore collegato, in questo caso la valutazione.

Vediamo quindi la formula da inserire in F4 per restituire il valore corretto e corrispondente a un punteggio di 12 punti.

In questo caso, non abbiamo riferimenti per 12 nell’intervallo iniziale ma Excel restituisce correttamente F poichè corrispondente ai punteggi da 10 a 20. CERCA.VERT considera sempre il valore più vicino inferiore a quello inserito.

=CERCA.VERT(E4;$B$4:$C$11;3;VERO)

In particolare:

– E4 è il valore di partenza, ovvero il punteggio 12. Questo valore si trova nella colonna B all’interno del primo intervallo

– $B$4:$D$11 è la matrice_tabella o intervallo di ricerca, dove sono contenuti sia i punteggi sia le valutazioni

– 3 è l’indice poichè stiamo cercando le valutazioni che si trovano sulla terza colonna (la colonna 1 racchiude gli intervalli di punteggio, la colonna 2 l’anno di riferimento e la colonna 3 la relativa valutazione)

– VERO è l’intervallo perchè desideriamo la corrispondenza approssimativa, ovvero il valore che più si avvicina a quanto stiamo cercando



Scopri altri casi pratici per la funzione CERCA.VERT: