CONFRONTA

La funzione CONFRONTA in Excel

La funzione CONFRONTA è utilizzata per individuare la posizione di un certo valore all’interno di un intervallo.

La notazione su Excel della funzione è:

=CONFRONTA(valore;matrice;[corrisp])

Per procedere ci serviranno quindi:
– un valore da ricercare
– una matrice nella quale effettuare la ricerca
– una corrispondenza da definire se esatta, minore o maggiore

Vediamo alcuni casi per semplificare la comprensione, essendo una funzione piuttosto sfaccettata nel suo utilizzo su Excel.

Caso 1: vogliamo individuare la posizione di una stringa di testo all’interno di un intervallo di celle.

In questo caso, inseriamo “Aprile” nella cella B3 e consideriamo come intervallo B1:B16.

La funzione ci permette di cercare la posizione del testo nell’intervallo:

=CONFRONTA(B3;B1:B16;0)

Il risultato sarà 3, poichè è il terzo valore dell’intervallo. Se avessimo inserito la funzione come:

=CONFRONTA(“Aprile”;B1:B16;0)

il risultato sarebbe stato sempre pari a 3.

Caso 2: cercare un valore a destra, sinistra, sopra o sotto una certa cella all’interno di un intervallo.

In questo caso la funzione richiede di essere impiegata con la funzione INDICE.

Poniamo ad esempio di voler restituire il valore a sinistra della cella C18, più nello specifico nella colonna A. L’intervallo considerato è da C1 a C25, così come nella colonna A sarà da A1 a A25.

La funzione viene utilizzata come segue:

=INDICE(A1:A25;CONFRONTA(C18;C1:C25;0)

Bisogna fare attenzione utilizzando questa combinazione dato che gli intervalli devono essere uguali, quindi vediamo come siano da 1 a 25 in entrambi gli intervalli.

Caso 3: cercare un valore all’interno di una tabella.

In questo caso dovremo usare INDICE con un doppio CONFRONTA, ti suggerisco di consultare questo articolo per scoprirne il funzionamento.


Scopri come utilizzare la funzione CONFRONTA su Excel: