INDICE

La funzione INDICE in Excel

La funzione INDICE è utilizzata per restituire il valore “n” all’interno di un certo intervallo o di una tabella.

=INDICE(matrice;riga;[col])

=INDICE(rif;riga;[col];[area])

Generalmente la funzione viene utilizzata con altre funzioni di Excel, ad esempio CONFRONTA, AGGREGA o CASUALE.TRA.

Vediamo alcuni casi tipici.

Caso 1: restituire il valore “n” di un intervallo.

In questo caso vogliamo restituire il settimo valore dell’intervallo fra B2 e B24, partendo da B2.

La funzione può compiere questa operazione in autonomia:

=INDICE(B2:B24;7)

Caso 2: in questo caso vogliamo restituire un valore “n” dinamico in un intervallo.

Utilizziamo l’intervallo precedente fra B2 e B24.

Inseriamo un valore numerico nella cella F4.

Anche in questo caso la funzione può compiere questa operazione in autonomia:

=INDICE(B2:B24;F4)

Caso 3: restituire un valore a sinistra di una certa cella se non ci sono duplicati.

Vogliamo trovare il valore nella colonna B relativo a “Maggio”, considerando l’intervallo da B2 a B42 e da C2 a C42.

Questa è una combinazione comune, nella quale INDICE si unisce a CONFRONTA per permettere di cercare valori a sinistra.

Vediamo come funziona:

=INDICE(B2:B42;CONFRONTA(“Maggio”;C2:C42;0))

Nella pratica, la funzione CONFRONTA individua dove si trovi il valore “Maggio” nell’intervallo da C2 a C42 e restituirà il valore che si trova sulla colonna adiacente. Ad esempio, se “Maggio” fosse in C18 la combinazione di funzioni restituirà B18.

Caso 4: restituire un valore a sinistra di una certa cella se ci sono duplicati. Vediamo in questo caso come risolvere con la funzione INDICE su Excel.

In questo caso, la combinazione è più complessa e richiede anche l’utilizzo della funzione AGGREGA.

Caso 5: la funzione permette di restituire un valore casuale da un elenco di nomi.

Assumiamo di avere alcuni nomi nelle celle da B3 a B14. Nella nostra simulazione in questo caso vogliamo avere un nome casuale e non un numero.

Un escamotage è utilizzare le funzioni CASUALE.TRA e CONTA.VALORI per aiutarci. Quindi in questo caso, se vogliamo avere un nome casuale, possiamo inserire la seguente formula:

=INDICE(B3:B14;CASUALE.TRA(1;CONTA.VALORI(B3:B14)))

Come funziona? In questo caso la funzione ci permette di orientarci nell’intervallo da B3 a B14.

CASUALE.TRA ci serve invece per navigare fra il numero 1 e il numero maggiore dell’intervallo, ovvero il numero di valori totali che viene calcolato con CONTA.VALORI. Questo assumendo che non ci siano dei vuoti, altrimenti dovremo contare il numero di valori nell’intervallo.

Caso 6: la funzione permette anche di restituire il valore su una tabella o matrice.

In questo caso, assumiamo di volerci spostare su una tabella da A1 a B14 e di voler restituire il valore che si trovi a una distanza (inclusa la cella di partenza) di 3 righe e 2 colonne.

La funzione in questo caso permette di inserire sia le righe sia le colonne:

=INDICE(A1:B14;3;2))

Scopri altri casi di utilizzo per la funzione INDICE: