SE.ERRORE

Come utilizzare la funzione SE.ERRORE su Microsoft Excel

La funzione SE.ERRORE è utilizzata per diversi motivi, principalmente per una questione di pulizia del foglio di lavoro.

La notazione su Excel della funzione è:

=SE.ERRORE(valore;valore_se_errore)

Vediamo alcuni casi per semplificare la comprensione, dato che è una funzione imprescindibile per avere una buona comprensione di Excel e creare fogli di lavoro leggibili senza difficoltà.

Caso 1: abbiamo un caso di utilizzo dove recuperiamo valori da due tabelle o intervalli e proviamo a metterli assieme.

Come notiamo, in questo caso abbiamo due elenchi dai quali vengono ricavate delle informazioni. Potrebbero però esserci degli errori, quindi puliamo la formula inserendo SE.ERRORE – in questo modo, anche le celle dalla J14 in poi, pur avendo una formula, sono vuote.

Nello specifico:

=SE.ERRORE(INDICE($B$7:$B$16;CONFRONTA(RIF.RIGA(A1);$C$7:$C$16;0));””)

Un caso simile è anche con funzioni quali CERCA.X (da Excel 365) o CERCA.VERT, come vediamo dall’immagine seguente:

Caso 2: divisioni.

Questo è un caso che capita spesso, in particolare se stiamo creando un file dove dobbiamo fare un calcolo di margine percentuale, variazione percentuale, crescita YoY etc. In altri casi magari stiamo dando la possibilità di dividere delle celle per un numero ed inavvertitamente viene inserito 0. Anche qui basta inserire SE.ERRORE per pulire la formula e renderla leggibile anche a terzi, visualizzare #DIV/0 non è mai un buon segnale.

Ad esempio:

SE.ERRORE(-VAL.FUT($F$4/12;B9;-$I$4;$G$4);””)

 

Scopri altri casi pratici per la funzione SE.ERRORE: